読者です 読者をやめる 読者になる 読者になる

TECHLOGICS

HYLOGICS分室。作業メモやガジェットのレビューなど、主に技術系のエントリを取り扱います。

【備忘録】SSDが故障したっぽい

Linux

Oculus Touchのセットアップをしようかなと思ってVM起動して数時間(寝落ちしてた)後、Windowsの反応がないのでおかしいな?と思って強制停止をかけたところ、9月に購入して慣らし運転をしていたSSDがOSから見えていないことが発覚。

$ sudo virsh dumpxml gtx970

    <disk type='block' device='disk'>
      <driver name='qemu' type='raw'/>
      <source dev='/dev/sdg'/>
      <target dev='sda' bus='sata'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>

VM以前にホスト上から見えてない。そりゃ反応もなくなるよね、と。

$ ls /dev/sdg*
ls: cannot access /dev/sdg*: No such file or directory

ログを見るとH/Wエラーみたいなのでサポートに投げるしかなさそうです。

[771396.111434] ata10: exception Emask 0x52 SAct 0x0 SErr 0x5a80c01 action 0xe frozen
[771396.113375] ata10: irq_stat 0x00000040, connection status changed
[771396.115542] ata10: SError: { RecovData Proto HostInt 10B8B BadCRC LinkSeq TrStaTrns DevExch }
[771396.117404] ata10: hard resetting link
[771396.842104] ata10: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[771396.844407] ata10.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[771396.846261] ata10.00: revalidation failed (errno=-5)
[771401.844031] ata10: hard resetting link
[771402.151072] ata10: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[771402.153206] ata10.00: failed to IDENTIFY (I/O error, err_mask=0x100)
[771402.155362] ata10.00: revalidation failed (errno=-5)
[771402.157682] ata10: limiting SATA link speed to 1.5 Gbps
[771407.153065] ata10: hard resetting link
[771407.460069] ata10: SATA link down (SStatus 0 SControl 310)
[771407.462098] ata10.00: disabled
[771407.464124] ata10: EH complete
[771407.465048] sd 9:0:0:0: rejecting I/O to offline device
[771407.465051] sd 9:0:0:0: [sdg] killing request
[771407.465056] sd 9:0:0:0: rejecting I/O to offline device
[771407.465072] sd 9:0:0:0: [sdg]  
[771407.465074] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[771407.465075] sd 9:0:0:0: [sdg] CDB: 
[771407.465081] Write(10): 2a 00 00 6b 16 70 00 00 08 00
[771407.465084] blk_update_request: I/O error, dev sdg, sector 7018096
[771407.465086] Buffer I/O error on dev sdg, logical block 877262, lost async page write
[771407.482681] ata10.00: detaching (SCSI 9:0:0:0)
[771408.698666] sd 9:0:0:0: [sdg] Synchronizing SCSI cache
[771408.699357] sd 9:0:0:0: [sdg]  
[771408.700020] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[771408.700663] sd 9:0:0:0: [sdg] Stopping disk
[771408.701321] sd 9:0:0:0: [sdg] START_STOP FAILED
[771408.701996] sd 9:0:0:0: [sdg]  
[771408.702646] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[771437.508780] Buffer I/O error on dev sdg, logical block 877280, lost async page write
[771437.510586] Buffer I/O error on dev sdg, logical block 878302, lost async page write

対象はSillicon PowerのSP480GBSS3S55S25FR

SSDRAID組むべきなのかなあと思いつつ、ゲーム/お絵描き用の仮想マシン専用なので普段そんなに使ってるわけでもなくコスト的にちょっと辛い感じ。

それにしても、今年はざっと思い出せるだけで

と故障が相次いでおり非常に辛いところです(´・ω・`)